Adaptive Inter-frame Spacing

Compensates for excessive Ethernet packet collisions by dynamically controlling back-to-back timing.

When this feature is enabled, the network adapter dynamically adapts to network traffic conditions. The default setting works best for most computers and networks. In some rare cases you can obtain better performance by changing this setting.

Note: Changing this setting may cause a momentary loss of connectivity.


Adaptive Performance Tuning

Sets the number of frames the adapter receives before triggering an interrupt. Under normal operation, the adapter generates an interrupt every time a frame is received.

Move the slider towards Computer Performance to increase the number of frames the adapter receives before generating an interrupt. Doing so improves the computer's performance, but may reduce adapter bandwidth.

Note: Changing this setting may cause a momentary loss of connectivity.


Adaptive Technology

Optimizes performance based on the operating system.

To ensure best possible performance, leave Adaptive Technology on.

Notes:
  • Disable Adaptive Technology when troubleshooting adapter compatibility issues. Disabling Adaptive Technology also disables Transmit Control Blocks and Adaptive Performance Tuning.
  • If you disable this feature, you must enable Adaptive Inter-Frame Spacing.
  • Changing this setting may cause a momentary loss of connectivity.


Adaptive Inter-frame Spacing for PRO/100

Compensates for excessive Ethernet packet collisions on the network. Setting this value to 0 disables the feature.

The recommended setting (1) works best for most computers and networks by dynamically adapting to the network traffic conditions. This dynamic mode is active only when the value is set to 1. However, in some rare cases you might obtain better performance by manually setting the spacing value. Setting a value forces a static gap between packets.

Increasing the value increases the delay between frames being transmitted.

Note: Changing this setting may cause a momentary loss of connectivity.


Adaptive Transmit Threshold

Specifies the number of bytes the adapter stores in its transmit buffer before sending. For example, if the Adaptive Transmit Threshold value is 100, the adapter stores 100 bytes in its buffer before sending the data.

The adapter uses the Adaptive Transmit Threshold value as a starting point only. If the adapter is able to achieve better transmit performance using a lower value, it automatically adjusts to that value.

Recommended value If the computer has multiple bus mastering cards or high latency, set this value to 200.
If the computer has a single bus mastering card, set this value to 12.

To configure the adapter to first transmit full Ethernet frames and then adjust for best performance, set this value to 190. If transmit performance drops significantly with a value of 190, set the threshold to 16 and then incrementally increase it.

Note: Changing this setting may cause a momentary loss of connectivity.


Coalesce Buffers

Sets number of buffers available for transmit acceleration. Changing this setting can significantly increase transmit performance by enabling the adapter to join data segments before packet transmission.

To enhance performance, the Coalesce Buffers setting must be configured to work with the Transmit Descriptors setting. The Coalesce Buffers setting should be 30 - 50% of the Transmit Descriptors value. If the Coalesce Buffers setting is not modified to match the Transmit Descriptors setting, transmit performance might not be enhanced.

Recommended value 8
Note: Changing this setting may cause a momentary loss of connectivity.


TCP/IP Offloading Options

Allows you to specify which TCP/IP offload settings are handled by the adapter rather than the operating system.

Enabling offload settings increases transmission performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

Note: Changing this setting may cause a momentary loss of connectivity.


Performance Options

Configures the adapter to use settings that can improve adapter performance.


Enable PME

Allows the adapter to wake an Advanced Power Management (APM) enabled system from an S5 state. Also, some ACPI systems may be awakened from an S5 state if the system's BIOS supports it.

Disabled | Disables wake-up from an S5 state.
Enabled | Allows wake-up from an S5 state.
OS Controlled | Enables the adapter to use the operating system’s default settings.
Note: Changing this setting may cause a momentary loss of connectivity.


Flow Control Settings

Enables adapters to generate or respond to flow control frames, which help regulate network traffic. For an overview of this feature, click here.

Respond | The adapter pauses transmission when it receives a flow control frame from a link partner.
Generate | The adapter generates a flow control frame when its receive queue reaches a pre-defined limit.
Generate and Respond | The adapter generates and responds to flow control frames.
Off | The adapter does not generate or respond to flow control frames.
Notes:
  • For adapters to benefit from this feature, link partners must support flow control frames.
  • Changing this setting may cause a momentary loss of connectivity.


Flow Control Settings

Enables adapters to generate or respond to flow control frames, which help regulate network traffic. For an overview of this feature, click here.

Tx Enabled | The adapter pauses transmission when it receives a flow control frame from a link partner.
Rx Enabled | The adapter generates a flow control frame when its receive queue reaches a pre-defined limit.
Rx & Tx Enabled | The adapter generates and responds to flow control frames.
Disabled | The adapter does not generate or respond to flow control frames.
Notes:
  • For adapters to benefit from this feature, link partners must support flow control frames.
  • Changing this setting may cause a momentary loss of connectivity.


Giant Send Offload v4

Sets the adapter to offload the task of segmenting TCP messages into valid Ethernet frames.

Because the adapter hardware is able to complete data segmentation much faster than operating system software, this feature may improve transmission performance. In addition, the adapter uses fewer CPU resources.

Note: Changing this setting may cause a momentary loss of connectivity.


Giant Send Offload v6

Sets the adapter to offload the task of segmenting TCP messages into valid Ethernet frames.

Because the adapter hardware is able to complete data segmentation much faster than operating system software, this feature may improve transmission performance. In addition, the adapter uses fewer CPU resources.

Note: Changing this setting may cause a momentary loss of connectivity.


Gigabit Master Slave Mode

Determines whether the adapter or link partner is designated as the master. The other device is designated as the slave. Changing the setting may improve link quality with certain link partners.

CAUTION: Some multi-port devices may be forced to Master Mode. If the adapter is connected to such a device and is configured to "Force Master Mode", link is not established. Forcing the adapter to master or slave setting can break link if the link partner is not configured correctly.
Note: Changing this setting may cause a momentary loss of connectivity.


Header Data Split

Enables the adapter to split the header information from an incoming packet so the CPU does not have to process the whole packet, reducing CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


Interrupt Moderation

This sets the rate at which the controller moderates or delays the generation of interrupts making it possible to optimize network throughput and CPU utilization. The default setting (Adaptive) adjusts the interrupt rates dynamically depending on traffic type and network usage. Choosing a different setting may improve network and system performance in certain configurations.

Without interrupt moderation, CPU utilization increases at higher data rates because the system must handle a larger number of interrupts. Interrupt moderation causes the network driver to accumulate interrupts and send a single interrupt rather than a series of interrupts. At higher data rates, a high interrupt moderation setting may improve system performance. At low data rates, a lower interrupt moderation setting is preferred as delayed interrupts causes latency.

Note: Changing this setting may cause a momentary loss of connectivity.


Interrupt Moderation

Allows the adapter to moderate interrupts.

When a packet arrives the adapter generates an interrupt which allows the driver to handle the packet. At greater link speeds, more interrupts are created, and CPU utilization also increases. This results in poor system performance. When you enable Interrupt Moderation, the interrupt rate is lower, and the result is better system performance.

Note: Changing this setting may cause a momentary loss of connectivity.


IP Checksum Offload v4

Enables the adapter to verify the IP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve IP performance and reduce CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


IP Checksum Offload v6

Enables the adapter to verify the IP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve IP performance and reduce CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


Jumbo Frames

Enables Jumbo Frame capability for TCP/IP packets. In situations where large packets make up the majority of traffic and additional latency can be tolerated, Jumbo Frames can reduce CPU utilization and improve wire efficiency.

Jumbo Frames are larger than standard Ethernet frames, which are approximately 1.5k in size.

Note: Changing this setting may cause a momentary loss of connectivity.

Usage Considerations

  • Enable Jumbo Frames only if devices across the network support them and are configured to use the same frame size. When setting up Jumbo Frames on other network devices, note that different network devices calculate Jumbo Frame sizes differently. Some devices include the header information in the frame size while others do not. Intel adapters do not include header information in the frame size.
  • Using Jumbo frames at 10 or 100 Mbps may result in poor performance or loss of link.
  • When configuring Jumbo Frames on a switch you may need to increase the frame size over the adapter's setting. Set the switch's frame size four bytes higher for CRC, plus four bytes if you are using VLANs or QoS packet tagging.


Jumbo Packets

Enables Jumbo Packet capability for TCP/IP packets. In situations where large packets make up the majority of traffic and additional latency can be tolerated, Jumbo Packets can reduce CPU utilization and improve wire efficiency.

Jumbo Packets are larger than standard Ethernet frames, which are approximately 1.5k in size.

Note: Changing this setting may cause a momentary loss of connectivity.

Usage Considerations

  • Enable Jumbo Packets only if devices across the network support them and are configured to use the same frame size. When setting up Jumbo Packets on other network devices, note that different network devices calculate Jumbo Packet sizes differently. Some devices include the header information in the frame size while others do not. Intel adapters do not include header information in the frame size.
  • Using Jumbo Packets at 10 or 100 Mbps may result in poor performance or loss of link.
  • When configuring Jumbo Packets on a switch you may need to increase the frame size over the adapter's setting. Set the switch's frame size four bytes higher for CRC, plus four bytes if you are using VLANs or QoS packet tagging.


Locally Administered Address

Changes the MAC address used by this network adapter. The address is a 12-digit hexadecimal number in this range: 0000 0000 0001 - FEFF FFFF FFFF

CAUTION: Make sure no other systems on the network use this address.

Notes

  • Do not use a multicast address (least significant bit of the high byte = 1).
    For example, in the address 0y123456789A, "y" cannot be an odd number. (y must be 0, 2, 4, 6, 8, A, C, or E.)
  • To restore the default MAC address, click Use Default.
  • You cannot change the address if the adapter is part of a team.
  • Changing this setting may cause a momentary loss of connectivity.


Log Link State

Enables the logging of the following link state changes to the system event log.

  • LINK_UP_CHANGE
    Indicates that the adapter has established link.
  • LINK_DOWN_CHANGE
    Indicates that the adapter has lost link.
  • LINK_DUPLEX_MISMATCH
    Indicates a mismatch in duplex between the adapter and the link partner.

Troubleshooting tip: To investigate connection problems, click the Link Speed tab and run diagnostics.

Note: Changing this setting may cause a momentary loss of connectivity.


Low Resource Connectivity

When this setting is enabled, the network adapter maintains network connectivity even if the system does not have enough resources to run all of the advanced settings, such as IPSec Offload and Large Send Offload. Advanced features resume only when you restart the computer.

To identify resource issues, check the system event log, which displays errors occurring as a result of low system resources.

Note: Changing this setting may cause a momentary loss of connectivity.


Max RSS CPU

Sets the maximum number of logical processors available for Receive Side Scaling (RSS). This should be set to 2 or 4 if “Virtual Machine Queues” is enabled on a Hyper-V enabled system.


Offload IP Security

Saves CPU cycles by offloading IPSec encryption from the CPU to the adapter.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Offload TCP Receive Checksum

Enables the adapter to verify the TCP or UDP checksum of incoming packets. This feature enhances receive performance and reduces CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


Offload TCP Segmentation

Enables the adapter to offload the task of segmenting TCP messages into valid Ethernet frames.

Because the adapter hardware is able to complete data segmentation much faster than operating system software, this feature may improve transmission performance. In addition, the adapter uses fewer CPU resources.

Note: Changing this setting may cause a momentary loss of connectivity.


Offload TCP/IP Checksum

Enables the adapter to verify the TCP/IP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve TCP/IP performance.

Note: Changing this setting may cause a momentary loss of connectivity.


Transmit IP Checksum

Enables the adapter to compute the IP checksum of transmitted packets. This feature may improve IP transmit performance and will reduce CPU utilization. With Offloading disabled, the operating system verifies the IP checksum.

Note: Changing this setting may cause a momentary loss of connectivity.


Offload Transmit TCP Checksum

Enables the adapter to compute the TCP or UDP checksum of transmitted packets. This feature may improve TCP and UDP transmit performance and will reduce CPU utilization. With Offloading enabled, the adapter completes the verification for the operating system.

Notes:
  • Disable this feature when the server is supporting DOS-based clients.
  • Changing this setting may cause a momentary loss of connectivity.


PCI Bus Efficiency

Combines transmit packet buffer fragments into a single buffer before sending them to the network.

  • When PCI Bus Efficiency is disabled, the adapter uses the transmission method that provides the best possible performance. If coalescing packets provides the best transmission performance, the adapter will automatically coalesce packets.
  • When PCI Bus Efficiency is enabled, the adapter forces packet coalescing.

Disable PCI Bus Efficiency if there are no problems with packet transmission performance. If there are a high number of underruns, or the PCI Bus exhibits performance problems, enable this setting.

Note: Changing this setting may cause a momentary loss of connectivity.


Direct Cache Access

Direct Cache Access (DCA) reduces the number of memory access operations required to process each packet by delivering packet data directly to system CPU cache.

Notes:
  • DCA is only available if the processor, chipset, and network device all support it.
  • Changing this setting may cause a momentary loss of connectivity.


Low Latency Interrupts General

Enables adapters to bypass interrupt moderation and immediately generate an interrupt when certain TCP packets arrive, allowing the system to handle the packet more quickly. Certain applications will have faster access to network data because of the reduced data latency.

Notes:
  • If this option is enabled, system CPU utilization may increase.
  • Changing this setting may cause a momentary loss of connectivity.


Low Latency Interrupts Properties

Configures which packets bypass interrupt moderation and trigger immediate interrupts.

Use for packets with TCP PSH flag: | Any incoming packet with the TCP PSH flag will trigger an immediate interrupt. The PSH flag is set by the sending device.
Use for these TCP ports: | Every packet received on the specified ports will trigger an immediate interrupt. Up to 8 ports may be specified.
Note: Changing this setting may cause a momentary loss of connectivity.


Preferred NUMA Node

Allows the user to choose the preferred NUMA (Non-Uniform Memory Access) node to be used for memory allocations made by the network adapter. In addition the system will attempt to use the CPUs from the preferred NUMA node first for the purposes of RSS. On NUMA platforms, memory access latency is dependent on the memory location. Allocation of memory from the closest node helps improve performance. The Windows Task Manager shows the NUMA Node ID for each processor.

Note: This setting only affects NUMA systems. It will have no effect on non-NUMA systems.


Priority Level Definition

If the computer has 802.1p/802.1Q tagging (QoS) enabled, you can define the priority levels serviced by the priority queues. Intel adapters have two priority queues: high and low.

The number you specify sets the lower limit of the high priority queue.

For example, if you enter 6, packets with a priority of 0-5 are sent through the low priority queue, and packets with a value of 6-7 are sent through the high priority queue.

Note: Changing this setting may cause a momentary loss of connectivity.


Priority VLAN tag

This feature enables sending and receiving IEEE 802.3ac tagged frames.

  • Priority: 802.1p QoS (Quality of Service) tags for priority-tagged packets
  • VLAN: 802.1Q tags for VLANs

Tagged packets use the queue settings defined by the operating system's Priority Level Definition.

Tagging is automatically enabled when you set up a VLAN on the VLAN tab. If you have a tagged VLAN set up, you will not be able to disable tagging.

Notes:
  • Advanced Networking Services (ANS) must be installed to set up VLANs.
  • Changing this setting may cause a momentary loss of connectivity.


QoS Packet Tagging

Enables sending and receiving of IEEE 802.3ac tagged frames, which include

  • 802.1p QoS (Quality of Service) tags for priority-tagged packets
  • 802.1Q tags for VLANs

When this feature is enabled, tagged packets use the queue settings defined by the operating system's Priority Level Definition.

QoS Packet Tagging is automatically enabled when you set up a VLAN on the VLAN tab. You cannot disable tagging because tagging is required for VLANs.

Notes:
  • Advanced Networking Services (ANS) must be installed to set up VLANs.
  • Changing this setting may cause a momentary loss of connectivity.


Retransmit Inter-Frame Spacing

Increases the delay between frame retransmissions. Although there is a built-in Ethernet algorithm that adapters use for retransmitting frames after collisions, increasing the delay can improve network performance if there is an abnormally large number of collisions on the network.

Note: Changing this setting may cause a momentary loss of connectivity.


RSS

Enables Receive Side Scaling (RSS). RSS balances receive traffic across multiple CPUs or CPU cores. This setting has no effect if your system has only one processing unit.

Notes:
  • RSS must be enabled for Intel® I/O Acceleration Technology to function.
  • Changing this setting may cause a momentary loss of connectivity.

Teaming Notes

  • If RSS is not enabled for all adapters in a team, RSS will be disabled for the team.
  • If an adapter that does not support RSS is added to a team, RSS will be disabled for the team.
  • If a non-Intel adapter is added to a team, RSS will be disabled for the team.
  • Non-Intel adapters with RSS enabled cannot be added to a team.
  • Not all adapters support all RSS queue settings.


RSS Queues

Configures the number of RSS queues:

  • 1 queue is used when low CPU utilization is required.
  • 2 queues is used when good throughput and low CPU utilization are required.
  • 4 or more queues are used for applications that demand high transaction rates such as web server based applications. With this setting, the CPU utilization may be higher.
Notes:
  • Not all adapters support all RSS queue settings.
  • Using 8 or more queues on Microsoft* Windows Server* 2008 will require the system to reboot.
  • Changing this setting may cause a momentary loss of connectivity.


Receive Buffers

Sets the number of Receive Buffers used by the adapter when copying data to memory. Increasing this value can enhance receive performance, but also consumes system memory.

You might choose to increase the number of Receive Buffers if you notice a significant decrease in the performance of received traffic. If receive performance is not an issue, use the default setting.

Note: Changing this setting may cause a momentary loss of connectivity.


Receive Descriptors

Sets the number of Receive Descriptors used by the driver when copying data to the protocol memory. Increasing this value can enhance receive performance, but also consumes system memory.

Receive Descriptors are data segments that enable the adapter to allocate received packets to memory. Each received packet requires one Receive Descriptor, and each descriptor uses 2KB of memory.

You might choose to increase the number of Receive Descriptors if you notice a significant decrease in the performance of received traffic. If receive performance is not an issue, use the default setting.

Note: Changing this setting may cause a momentary loss of connectivity.


Security Associations

Specifies the number of simultaneous Security Associations that can be offloaded to the adapter. A security association is a communication session with another computer running IP Security software.

If the computer is capable of supporting more Security Associations than what is specified as the default, increase this value. Note that increasing the number of Security Associations increases the memory consumption of the adapter.

NOTE: Changing this setting may cause a momentary loss of connectivity.


Smart Speed

Enables the device downshift the link speed if the connection is of insufficient quality to support the highest speed. Set to disable if you don't want the device to downshift its link speed.

Note: Changing this setting may cause a momentary loss of connectivity.


Starting RSS CPU

Allows the user to set the preferred starting RSS processor. Change this setting if the current processor is dedicated to other processes. The setting range is from 0 to the number of logical CPUs - 1. In Server 2008 R2, RSS will only use CPUs in group 0 (CPUs 0 through 63).


TCP Checksum Offload v4

Enables the adapter to verify the TCP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve TCP performance and reduce CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


TCP Checksum Offload v6

Enables the adapter to verify the TCP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve TCP performance and reduce CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


Transmit Buffers

Sets the number of Transmit Buffers used by the adapter when copying data to memory. Increasing this value can enhance transmission performance, but also consumes system memory.

You might choose to increase the number of Transmit Buffers if you notice a significant decrease in the performance of transmitted traffic. If transmission performance is not an issue, use the default setting.

Note: Changing this setting may cause a momentary loss of connectivity.


Transmit Descriptors

Defines the number of Transmit Descriptors, which are data segments that enable the adapter to track transmit packets in the system memory. Depending on the size of the packet, each transmit packet requires one or more Transmit Descriptors.

You might choose to increase the number of Transmit Descriptors if you notice a problem with transmit performance. Increasing the number of Transmit Descriptors can enhance transmit performance. However, Transmit Descriptors consume system memory. If transmit performance is not an issue, use the default setting.

Note: Changing this setting may cause a momentary loss of connectivity.


UDP Checksum Offload v4

Enables the adapter to verify the UDP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve UDP performance and reduce CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


UDP Checksum Offload v6

Enables the adapter to verify the UDP checksum on received packets and compute checksum on transmitted packets. Enabling this feature may improve UDP performance and reduce CPU utilization.

Note: Changing this setting may cause a momentary loss of connectivity.


VMQ

Enables Virtual Machine Queue (VMQ) Filter offloading. This offloads the filtering of receive and transmit traffic for each virtual machine into the adapter hardware. Filtering is based on MAC and/or VLAN filters.

Enabling VMQ Filter offloading increases receive and transmit performance, as the adapter hardware is able to perform these tasks faster than the operating system. Offloading also frees up CPU resources.

Note:
  • Enabling this setting will enable VMQ on Microsoft's VM switch.
  • Changing this setting may cause a momentary loss of connectivity.

Teaming Considerations

  • If VMQ is not enabled for all adapters in a team, VMQ will be disabled for the team.
  • If an adapter that does not support VMQ is added to an existing team, VMQ will be disabled for the team.


Wait for Link

Determines whether the driver waits for automatic detection or negotiation to be successful before reporting the link state.

Options

Off: Driver does not wait for automatic detection or negotiation.

On: Driver does wait for automatic detection or negotiation. If the adapter is not set to automatically detect or negotiate speed, the driver waits for a short time for link to complete and then reports the link state.

Auto Detect: Automatically set to On or Off depending on speed and adapter type when the driver is installed.

  • Off for copper Intel Gigabit adapters set to automatically detect or negotiate speed.
  • On for copper Intel Gigabit adapters set to force speed and duplex.
  • On for fiber Intel Gigabit adapters.
Note: Changing this setting may cause a momentary loss of connectivity.


FCoE Advanced Tab

Opens Intel® Proset for Windows* Device Manager for the selected adapter.


FCoE Properties

Boot Targets: | The server side system in an FCoE SAN configuration. The FCoE Boot Target system hosts the FCoE target drives which are accessed by an FCoE Boot initiator.
Properties: | Click on Properties button with Boot Targets selected to launch Target Properties Dialog.
Update Flash: | Click on Update Flash button to allow Intel® FCoE Boot FLB to be written. The FCoE Boot update operation writes a new FCoE Boot image to the adapter's Flash and modifies the EEPROM, which may temporarily disable the operation of the Windows* network device driver. You might need to reboot the computer following this operation. Note: You cannot update the flash image of a LOM; this button will be disabled.


FCoE Properties

Target: | Contains WWPN numbers for the FCoE boot targets discovered on the network and None Selected.
LUN: | Displays the LUNs on the selected target. If no target is selected, the LUN field is empty.
Boot Order: | Options are 1, 2, 3, 4, and Not Set.

LUN and Boot Order fields are disabled and cleared when target is set to None Selected.

FCoE Boot cannot be enabled on an adapter that has a VLAN or is in a team. If the current adapter is in a team or has a VLAN, then all fields are disabled.


Device Queue Depth

Changes the Drive I/O Queue Depth value. This change may affect driver performance. Values for this setting are between 1-252 in increments of 1.


Linkdown Timeout

Changes the time limit that I/O will be held on a link down. This value supersedes the Timeout Value setting.


FCoE Properties

FCoE Boot is not supported on the current Operating System or FCoE stack is not installed. FCoE Boot is supported on these operating systems:

  • Microsoft* Windows Server* 2003 SP2, R2 x86
  • Microsoft Windows Server 2008 DataCenter or Enterprise

Update Flash:

Flash updates are not supported for LOMs.


Timeout Value

Time in units of seconds before an SRB request initiated by the disk class driver will time out.

For FCoE, valid values range from 1 to 255 seconds.

Note: A restart is required to implement Timeout Value setting changes.


FCoE VLAN ID

VLANs

VLAN IDs are obtained through FIP VLAN discovery. This is a read-only page.

Status Options: "In Use” and “Not In Use”


Boot IBA Mode

Allows network administrators to change the Intel® Boot Agent settings and update the Intel Boot Agent software or to update the flash image to Intel® iSCSI Remote Boot.

For more information, see the Intel Boot Agent User's Guide or Intel® iSCSI Remote Boot User's Guide on the installation CD or downloaded files.

Update Flash Image

Allows an Intel® iSCSI Remote Boot, Intel® Boot Agent (IBA), and EFI flash image to be written. The update operation writes a new image to the adapter's flash. This may temporarily disable the operation of the Windows* network device driver. You may need to reboot the computer following this operation.

After clicking the Update Flash button, navigate to the BOOTAGNT directory and double-click the FWxxxxDE.FLB file. This will update the combo image containing Intel iSCSI Remote Boot, Intel Boot Agent (IBA), and EFI.
Apply Changes Implements changes that you made to the settings.


This network connection is disabled

This network connection is disabled or has been removed from the system.

You must reinstall the connection or enable it from the General tab before you can access disabled features.


This network connection is disabled

This network connection is disabled or has been removed from the system.

You must reinstall the connection or enable it from the General tab before you can access disabled features.

NOTE: This device supports Device Sleep on Disconnect. If the network cable is not attached to the device, attaching the cable or disabling the Device Sleep on Disconnect setting on the Power Management tab may enable it.


Power Management Tab

The options on this tab extend the capabilities of the standard Power Management options. Highlighting an option will display help information on that option. Power Saver Options determine when and how the adapter reduces power consumption. Wake on LAN options allow you to specify which events will wake the computer.

Unless Wake on LAN options are enabled, Intel® adapters always allow the computer to power down the device when the computer is hibernating or in standby.


Auto Connect Battery Saver (ACBS)

Enables the Intel® Auto Connect Battery Saver (Intel® ACBS) feature. This turns off the adapter when link is down or the network cable is disconnected. After a timeout period, the adapter will power off.

When the network cable is reconnected and link is restored, the NIC powers up and functionality is fully restored.

NOTES:
  • This feature only works when the system is on battery power. If the power cable is connected, Intel® ACBS will be automatically disabled.
  • Intel® ACBS will not function on an adapter if the adapter has forced speed or duplex settings. Intel® ACBS will only function if the adapter is set to automatically detect or negotiate speed and duplex.
  • ACBS will not be activated if your system enters a low power state (standby, hibernate, or power down) with the LAN cable still connected. To activate ACBS, disconnect the LAN cable and wait at least 15 seconds before putting your system into a low power state.


Deep Smart Power Down

Turns off the adapter when link is down or the network cable is disconnected. After a timeout period, the adapter will power off. To the operating system, this appears as a "hot-unplugged" adapter.

When the network cable is reconnected and link is restored, the NIC powers up and functionality is fully restored. This appears as a "hot-plugged" adapter.


Enhanced ASPM

Saves power when the adapter is active by entering the L1 PCI Express low-power link state when there are no outstanding requests or pending transactions.


Power Management Tab, No Power Saver Options

The options on this tab extend the capabilities of the standard Power Management options. Highlighting an option will display help information on that option. Wake on LAN options allow you to specify which events will wake the computer.

Unless Wake on LAN options are enabled, Intel® Network Adapters always allow the computer to power down the device when the computer is hibernating or in standby.

This port does not support Power Saver Options.


Power Management Tab, No WoL Options

The options on this tab extend the capabilities of the standard Power Management options. Highlighting an option will display help information on that option. Power Saver Options determine when and how the adapter reduces power consumption.

This port does not support Wake on LAN options.


Reduce Power When on Battery Power

Enables the Intel® Link Speed Battery Saver feature. Sets the adapter to negotiate the lowest possible speed setting while the computer is on battery power.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


Reduce Power When the Cable is Disconnected

Sets the adapter to reduce power consumption when the network cable is disconnected from the adapter or when the operating system is in Suspend mode. When the adapter regains a valid link, adapter power usage returns to its normal state (full power usage).

NOTE: When two Intel® PRO/1000 MT Desktop Adapters are connected back to back and this feature is enabled, there is no link between these adapters. You must disable this feature on both adapters when connecting them back to back.


Reduce Speed to Save Power

Enables the Intel® System Idle Power Saver feature. Sets the adapter to negotiate the lowest possible speed setting when the system and network is idle.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


Reduce Speed to Save Power

Sets the adapter to negotiate the lowest possible speed setting to conserve power.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.
NOTES:
  • When Power Saving is enabled, Intel® PRO/100 M Desktop Adapters slow down adapter processing cycles. This feature enables the adapters to further decrease power consumption. Other Intel adapters do not reduce processing cycles to conserve power.
  • Intel® Gigabit adapters must be connected to a switch to use this feature.


Reduce Power During Standby

Sets the adapter to negotiate the lowest possible speed setting to save power while the computer is in standby mode.

NOTES:
  • Wake on Magic Packet or Wake on Directed Packet must be enabled for this option to function.
  • Wake on Magic Packet from power off state has no effect on this option.

To support this feature, the adapter must be:

  • configured to automatically detect or negotiate speed.
  • connected to a link partner that can automatically negotiate speed.


Sleep on Disconnect

Sets the adapter to reduce power consumption when the network cable is disconnected from the adapter. When the adapter regains a valid link, adapter power usage returns to its normal state (full power usage).


Wake From S5

Allows the adapter to wake an Advanced Power Management (APM) enabled system from a power-off (S5) state. ACPI systems can wake from an S5 state if the system's BIOS supports it.


Wake on Directed Packet

Enables this device to bring the computer out of standby or hibernation when a packet is sent directly to the adapter.

For example, any attempt to remotely access files stored on the computer will wake it.


Wake On Link

Allows the adapter to wake an Advanced Power Management (APM) enabled system when the network connection establishes link.

ACPI systems can wake from standby (S3) or Hibernate (S4). If the system's BIOS supports it, ACPI systems can wake from a power-off (S5) state.

NOTES:
  • To wake from S5, you must enable the Wake on Magic Packet from power off state setting.
  • Link must be lost before the system enters an S5 state in order to wake the system with a link up event.


Wake On Magic Packet

Enables a management station to bring the computer out of standby or hibernation when a Magic Packet* is sent directly to the adapter.


Wake From S5

Intel® Remote Wake Technology keeps your network connection active when the rest of your system is in sleep or standby mode, so that content on your system is readily accessible. Requests from other computers will wake up your computer.


LinkSec Default

LinkSec general information

LinkSec is a set of IEEE link-layer standard protocols (including MACSec and KeySec) that provide effective data integrity, confidentiality, and origin authentication. It complements IEEE 802.1X in enterprise networks and provides secure, encrypted communication capable of identifying and preventing threats emanating from behind the firewall. LinkSec uses Extensible Authentication Protocol (EAP) as the authentication framework. NOTE: Enabling LinkSec will disable IPSec offloading.

Connect without using LinkSec: Do not authenticate when creating a network connection.

Use manual authentication keys: This option allows network administrators to determine the security settings.

Use 802.1x authentication when available: Creates a secure connection on network segments that use LinkSec but allows this device to connect to other network segments that do not require authentication. Select an authentication type from the drop down list.

Require 802.1x authentication: This option requires LinkSec in the network. If you do not have LinkSec in the network and you select this option, this device will not connect. Select an authentication type from the drop down list.

Use Manual Pairwise Master Key (PMK) for KeySec: Defines a static PMK for SAP.

TLS - Transport layer Security - for network segments employing the use of both client-side and server-side digital certificates of authenticity. Uses TLS as the encryption protocol. Requires PKI digital certificate infrastructure.

TTLS - Tunneled Transport Layer Security - uses client-side certificates of authenticity to open secure tunnels between devices to protect user names and other authentication credentials.

PEAP - Protected EAP - uses client-side certificates of authenticity and other forms of authentication security to establish secure tunnels between devices for the exchange of encryption information.

NOTE: To prevent possible "man-in-the-middle" attacks, Microsoft recommends that you do not use the same authentication method and credentials for PEAP and non-PEAP connections unless the non-PEAP connections are protected by Internet Protocol security (IPSec).

EAP-FAST - Extensible Authentication Protocol - Flexible Authentication via Secure Tunneling - utilizes other authentication techniques to establish a secure tunnel for the exchange of encryption information.


EAP-FAST properties

Select either MS-CHAPv2, GTC, or TLS as the method to be used for the exchange of authentication credentials between network devices through a secure tunnel.

NOTE: For EAP-FAST, the GTC method is appropriate for most situations. See the User Guide for details.
  • MS-CHAPv2, stands for “challenge handshake authentication protocol” and is a commonly used authentication protocol.

    Use Windows Domain machine credentials for machine authentication – enables authentication with a computer name and password registered in Windows domain. The authentication server must be capable of machine password verification and be in the same Windows domain as the supplicant machine.

  • GTC stands for “generic token card” originally designed for use with physical token cards.
  • TLS - The ACS server may require a client-side digital certificate of authority.

User name - enter a valid existing machine or system-wide user name.

Password – enter the user’s existing machine or system-access password.

Protected Access Credentials (PACs) – a unique shared credential file used to authenticate client and server. PAC files may be distributed to client devices automatically or manually using physical media.

Use automatic PAC – enables the use of an automatically generated PAC file, stored on the server and distributed to clients during EAP-FAST authentication. When unchecked, the user must provide a valid PAC file.


PAC Store Manager

Allows you to manage and view information about your stored PAC files.

Import: Import a PAC file into your stored list.

Remove: Remove the selected PAC file from your list.


Manual Authentication Properties

Authenticate and encrypt network connections using the following settings.

NOTE: Transmit values apply to the local device you are configuring. Receive values are taken from the link-partner device. Transmit values of one device correspond to the receive values of the link partner.

Security association key: Use any combination of 32 Hex characters. Make sure that the link-partner device uses these same characters (make sure that the transmit key for one device is the same as the receive key for the link partner).

Association numbers: Use any two mutually exclusive numbers. LinkSec uses these numbers to automatically manage security association keys.

Secure channel ID: Use any combination of 16 Hex characters for the transmit secure channel ID. Make sure that the link partner's receive-side secure channel ID is the same.

Include ID in packet headers: When checked, LinkSec places the secure channel ID in all transmitted packet headers.

Use Encryption: If checked, LinkSec will use both authentication and encryption. If unchecked, LinkSec will only use authentication for security. Data will be sent in the clear.


PMK properties

PMK Value: Enter the PMK value. It must be a hexadecimal value 256 bits (32 bytes) long.


TTLS properties

Select either MS-CHAPv2 or GTC, as the method to be used for the exchange of authentication credentials between network devices through a secure tunnel.

NOTE: For TTLS and PEAP, the MS-CHAPv2 method is appropriate for most situations. See the User Guide for details.
  • MS-CHAPv2, stands for “challenge handshake authentication protocol” and is a commonly used authentication protocol.

    Use Windows Domain machine credentials for machine authentication – enables authentication with a computer name and password registered in Windows domain. The authentication server must be capable of machine password verification and be in the same Windows domain as the supplicant machine.

  • GTC stands for “generic token card” originally designed for use with physical token cards.

User name – enter a valid existing machine or system-wide user name.

Password – enter the user’s existing machine or system-access password


Advanced Settings TOC

Advanced Settings

Jumbo Frames

Jumbo Packets

Locally Administered Address

Log Link State Event

Performance Options

Adaptive Inter-Frame Spacing

Direct Cache Access

Flow Control

Interrupt Moderation Rate

Low Latency Interrupts

Low Latency Interrupts Properties

Receive Descriptors

PRO100 Receive Descriptors

Transmit Descriptors

PRO100 Transmit Descriptors

Receive Buffers

Transmit Buffers

QoS Packet Tagging

TCP/IP Offloading Options

Offload Receive IP Checksum

Offload Receive TCP Checksum

Offload Transmit IP Checksum

Offload Transmit TCP Checksum

Offload TCP/IP Checksum

Offload TCP Segmentation

Offload IP Security

Wait for Link


Configuring Settings status page

Configuring. Please wait . . .


Flow Control Overview

A link partner can become overloaded if incoming frames arrive faster than the device can process them, and this results in the frames being discarded until the overload condition passes. The flow control mechanism overcomes this problem and eliminates the risk of lost frames.

If a potential overload situation occurs, the device generates a flow control frame, which forces the transmitting link partner to immediately stop transmitting and wait a random amount of time before trying to retransmit.


Legal Information

Copyright and Legal Disclaimers

Copyright © 2004 - 2009 Intel Corporation. All rights reserved.

*Other names and brands may be claimed as the property of others.

Intel Corporation assumes no responsibility for errors or omissions in this document. Nor does Intel make any commitment to update the information contained herein.

Intel, Itanium, and Pentium are trademarks of Intel Corporation in the U.S. and other countries.

Intel Corporation, 5200 N.E. Elam Young Parkway, Hillsboro, OR 97124-6497

Back


Intel 10GbE Link Page

Some Intel® 10GbE adapters can operate at both 10Gbps and 1Gbps. The link speed is dependent on the adapter’s link partner. You cannot change the speed setting for these adapters.

Copyright, legal disclaimers, and support information


Intel Gigabit Link Page

Speed and Duplex Setting. By default, Intel adapters are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner. The 1.0 Gbps Full Duplex setting sets the adapter to advertise only that speed during auto-negotiation.

SFP+ Modules

Some SFP+ Modules do not support all speeds that the Intel adapter is capable of. Only speeds that the adapter/module combination is capable of will be displayed in the drop down menu.

Copyright, legal disclaimers, and support information


Intel PRO/100 Link Page

Speed and Duplex Setting. By default, Intel adapters are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner.

Copyright, legal disclaimers, and support information


Intel Gigabit Link Page

Speed and Duplex Setting. By default, Intel® adapters are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner. The Auto-negotiate 1000Mbps setting sets the adapter to advertise only that speed during auto-negotiation.

Copyright, legal disclaimers, and support information


Intel Gigabit Fiber Link Page

Intel® Gigabit fiber and SerDes devices operate at 1000 Mbps. You cannot change the speed and duplex settings for this type of adapter.

Copyright, legal disclaimers, and support information


Intel Gigabit Link Page

Speed and Duplex Setting. By default, Intel adapters auto-negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner. The Auto-negotiate 1000Mbps setting sets the adapter to advertise only that speed during auto-negotiation.

Security. The status of Link-layer Security (LinkSec) on this device is displayed above. Access the security options by clicking the Security tab.

Tip: You can control Power Saver options on the Power Management tab.

Copyright, legal disclaimers, and support information


Intel Gigabit Link Page

Speed and Duplex Setting. By default, Intel® adapters are set to automatically detect and negotiate speed and duplex settings. If the adapter fails to connect, you can set the speed and duplex settings to match those of the link partner.

Copyright, legal disclaimers, and support information


Support

Web and Internet sites:

Customer Support:

http://www.intel.com/support

Network Products:

http://www.intel.com/products/ethernet/overview.htm

Download Site:

http://downloadfinder.intel.com

Copyright and Legal Disclaimers

Copyright © 2004 -2009 Intel Corporation. All rights reserved.

*Other names and brands may be claimed as the property of others.

Intel Corporation assumes no responsibility for errors or omissions in this document. Nor does Intel make any commitment to update the information contained herein.

Intel, Itanium, and Pentium are trademarks of Intel Corporation in the U.S. and other countries.

Intel Corporation, 5200 N.E. Elam Young Parkway, Hillsboro, OR 97124-6497